Issue loading video content

Incident Report for CybSafe Platform

Resolved

This issue is now resolved.
Posted Apr 07, 2025 - 16:45 BST

Investigating

We're aware of an issue with our video hosting platform causing intermittent issues loading video content. Our provider is investigating and working on a resolution.
Posted Apr 07, 2025 - 16:32 BST
This incident affected: CybSafe GUIDE and admin console.