Delays to Nudges sent via email

Incident Report for CybSafe Platform

Resolved

The backlog of email based Nudges is now resolved and we're fully operational again.
Posted May 30, 2025 - 17:37 BST

Update

We are continuing to monitor for any further issues.
Posted May 30, 2025 - 17:28 BST

Monitoring

We've experienced delays in sending a number email based nudges up to 18 hours, we have resolved the issue and expect the backlog to be resolved before 7pm BST.
Posted May 30, 2025 - 16:44 BST
This incident affected: CybSafe service emails.