Delay in PHISH emails to Microsoft 365 customers

Incident Report for CybSafe Platform

Monitoring

We're seeing a greater deliverability rate and are continuing to monitor.
Posted Jan 28, 2026 - 09:01 GMT

Investigating

We're investigating an increase in the number of deferred PHISH emails when sending to Microsoft 365 customers.
Posted Jan 27, 2026 - 13:45 GMT
This incident affects: CybSafe PHISH.